随着网络安全问题不断频发,传统补丁式外置安全方案已经不能满足业界需求,产业各方更希望从网络架构层实现内生安全,因此提出了去中心化可信网络架构。在研究现有网络底层协议安全的基础上,提出了基于去中心化技术/区块链技术的可信网络的架构方案,能够有效地解决现有网络缺乏内生安全的问题,并在中国下一代互联网(China’s Next Generation Internet,CNGI)进行了验证。此方案从协议层实现了网络安全,避免恶意网络攻击或者因配置失误造成的网络故障。
Abstract
With the frequent occurrence of network security issues
the industry had not satisfied the patch-based external security solution
and it was hoped that the endogenous security could be realized from the network architecture layer.The decentralized trustworthy network architecture was proposed.Based on the research of the security of existing network underlying protocol
a trustworthy network architecture based on decentralization technology was proposed
such as blockchain technology
which could effectively solve the problem of lack of endogenous security in existing networks.Layers implement network security to avoid malicious network attacks or network failures caused by configuration errors.
WU D F . 2018 global risk report ranked the top three for cyber attacks [J ] . Computer& Network , 2018 , 44 ( 4 ):1.
BUSH R . Origin validation operation based on the resource public key infrastructure (RPKI):RFC 7115 [S ] . 2014 .
HUSTON G , MICHAELSON G . Validation of route origination using the resource certificate public key infrastructure (PKI) and route origin authorizations (ROA):RFC6483 [S ] . 2012 .
LEPINSKI M , KENT S . An infrastructure to support secure internet routing:RFC 6480 [S ] . 2012 .
IETF . Problem definition and classification of BGP route leaks:7908 [S ] . 2016 .
LIU B Y , YANG F , REN S S , et al . Decentralized internet infrastructure [J ] . Telecommunications Science , 2019 , 35 ( 8 ): 74 - 87 .
CACHIN C , . Architecture of the hyperledger blockchain fabric [C ] // Workshop on Distributed Cryptocurrencies and Consensus Ledgers,July 25,2016,Chicago,USA.[S.l.:s.n] . 2016 .
ANGIERI S , GARCÍA-MARTÍNEZ A , LIU B , et al . An experiment in distributed internet address management using blockchains [J ] . arXiv:1807.10528 , 2018 .