Dongnian Cheng, Yufeng Li, Hailong Ma, et al. Initial Understanding and Practice of Network Services and Compositions[J]. Telecommunications science, 2013, 29(8): 38-43.
DOI:
Dongnian Cheng, Yufeng Li, Hailong Ma, et al. Initial Understanding and Practice of Network Services and Compositions[J]. Telecommunications science, 2013, 29(8): 38-43. DOI: 10.3969/j.issn.1000-0801.2013.08.006.
Initial Understanding and Practice of Network Services and Compositions
The current internet is simple in its fundamental interconnecting capability and is inflexible in its protocol architecture.Such a situation makes internet unable to well handle the variety of network applications' demands.Fortunately
a noval approach of so called“network service composition”can address the above problems.From the rationale of reductionism
the meanings of network services and their compositions were first explained.Several fundamental and key methods of network service composition were then presented
with relevent research projects shown.And finally
the ongoing work in the reconfigurable architecture of network infrastructures was introduced.
关键词
Keywords
references
Clark D . The design philosophy of the DARPA internet protocols . Computer Communication Review , 1988 , 18 ( 4 ): 106 ~ 114
Saltzer J , Reed D , Clark D . End-to-end arguments in system design . ACM Transactions on Computer Systems , Shanghai,China , 1984 , 2 ( 4 ): 277 ~ 288
RFC791.Internet Standard,Internet Protocol . 1981
Deering S , Hinden R . Internet Protocol Version 6(IPv6) Specification.RFC 2460 . 1998
RFC793.Internet Standard,Transmission Control Protocol . 1981
Anderson T , Peterson L , Shenker S , et al . Overcoming the internet impasse through virtualization . Computer , 2005 , 38 ( 4 ): 34 ~ 41
Auyang S Y . 复杂系统理论基础 . 田宝国 , 周亚 , 樊瑛 译. 上海 : 上海科技教育出版社 , 2002
Henke C , Siddiqui A , Khondoker R . Network functional composition:state of the art . Proceedings of Australasian Telecommunication Networks and Applications Conference , Christchurch,New Zealand , 2010 : 43 ~ 48
Ganapathy S , Wolf T . Design of a network service architecture . Proceedings of Sixteenth IEEE International Conference on Computer Communications and Networks(ICCCN) , Honolulu,HI , 2007
Srivastava V , Motani M . Cross-layer design:a survey and the road ahead . IEEE Communication Magazine , 2005 , 43 ( 12 ): 112 ~ 119
Schulzrinne H , Seetharaman S , Hilt V . NetSerV-architecture of a service-virtualized internet . NSF NeTS FIND Initiative , http://www.nets-find.net/Funded/Netserv.php http://www.nets-find.net/Funded/Netserv.php
Srinivasan S R , Lee J W , Liu E , et al . Netserv:dynamically deploying in-network services . Proceedings of the 2009 Workshop on Re-architecting the Internet(ReArch 2009) , New York,NY , 2009
Dutta R , Rouskas G , Baldine I , et al . The SILO architecture for services integration,control,and optimization for the future internet . Proceedings of the IEEE International Communications Conference on (ICC 2007) , Glasgow,Scotland , 2007 : 1899 ~ 1904
Baldine I . Future internet architecture:issues and non-issues,broadnets . org/2006/downloads/panel-find /baldine.pdf org/2006/downloads/panel-find /baldine.pdf
Open Networking Foundation . OpenFlow Switch Specification,V1.3.0 , 2012
Open Networking Foundation . Software-Defined Networking:the New Norm for Networks , 2012