
浏览全部资源
扫码关注微信
1. 法国电信北京研发中心 北京 100190
2. 中国电信股份有限公司北京研究院 北京 100035
Published Online:2013-09,
Published:20 September 2013
移动端阅览
Hong Lin, Song Wang, Xin Yang, et al. Research and Design of Mobile Client and Web Application Based on WebRTC Technology[J]. Telecommunications science, 2013, 29(9): 20-25.
Hong Lin, Song Wang, Xin Yang, et al. Research and Design of Mobile Client and Web Application Based on WebRTC Technology[J]. Telecommunications science, 2013, 29(9): 20-25. DOI: 10.3969/j.issn.1000-0801.2013.09.004.
WebRTC 具有开放标准、简单易扩展、开源免费等特点。除了通过调用 WebRTC 提供的标准Web API 方便快速开发 Web 应用外,还可以利用 WebRTC 的核心实现库开发高质量的实时音视频通信移动客户端应用。总结了 WebRTC 的主要技术特点,对设计和开发基于 WebRTC 技术的移动客户端应用和 Web 应用进行技术分析,给出基于 WebRTC 技术的移动客户端应用、Web 应用和服务平台的参考设计和实现。
WebRTC technology has some good characteristics of open and standardized
simple and extendable
open sourced and free. The Web applications can be easily and quickly developed by calling the Web API which are provided by WebRTC technology and being standardized. Besides
the mobile clients and applications of real-time audiovisual communications with high quality can also be developed by fully exploiting the WebRTC core implementation library. The main technical features of WebRTC technology were summarized. Based on the summary
the technical analysis was given about how to design and develop the mobile client application and Web application based on WebRTC technology. The reference design and the implementation of the mobile clients applications
the Web application and the service platform which supports these two kinds of the applications were provided.
WebRTC . http://www.webrtc.org http://www.webrtc.org
W3C HTML5 . http://www.w3.org/TR/html5/ http://www.w3.org/TR/html5/
IETF RTCWeb JSEP . JavaScript session establishment protocol . http://datatracker.ietf.org/doc/draft-ietf-rtcweb-jsep/ http://datatracker.ietf.org/doc/draft-ietf-rtcweb-jsep/ , 2013
IETF RFC5245 ICE . Interactive Connectivity Establishment , 2010
IETF RFC5389 STUN . Session Traversal Utilities for NAT , 2008
IETF RFC5766 TURN . Traversal Using Relays around NAT , 2010
W3C WebRTC Workgroup . http://www.w3.org/2011/04/webrtc-charter.html http://www.w3.org/2011/04/webrtc-charter.html
W3C WebRTC API . http://dev.w3.org/2011/webrtc/editor/webrtc.html http://dev.w3.org/2011/webrtc/editor/webrtc.html
IETF RTCWeb Workgroup . http://tools.ietf.org/wg/rtcweb/charters http://tools.ietf.org/wg/rtcweb/charters
10 3GPP TR 23.701.Study on the Support of WebRTC IMS Client Access to IMS , 2013
IETF RFC3951 iLBC . Internet Low Bit Rate Codec . 2004
IETF RFC3592 RTP iLBC . RTP Payload Format for Internet Low Bit Rate Codec Speech , 2004
IETF RFC6716 Opus . Definition of the Opus Audio Codec , 2012
WebM project . http://www.webmproject.org/ http://www.webmproject.org/
Global IP solutions . http://zh.wikipedia.org/wiki/Global_IP_Sound http://zh.wikipedia.org/wiki/Global_IP_Sound
IETF RFC6120 XMPP . Extensible Messaging and Presence Protocol
XMPP XEP-0166 Jingle . http://xmpp.org/extensions/xep-0166.html http://xmpp.org/extensions/xep-0166.html
IETF RFC3264 SDP . Session Description Protocol , 2002
Openfire . http://www.igniterealtime.org/projects/openfire/ http://www.igniterealtime.org/projects/openfire/
IETF RTCWeb JSEP XMPP/Jingle mapping . http://datatracker.ietf.org/doc/draft-li-rtcweb-jsep-xmpp-mapping/ http://datatracker.ietf.org/doc/draft-li-rtcweb-jsep-xmpp-mapping/
0
Views
1462
下载量
0
CSCD
Publicity Resources
Related Articles
Related Author
Related Institution
京公网安备11010802024621