
浏览全部资源
扫码关注微信
1. 中国电信股份有限公司北京研究院 北京100035
2. 法国电信北京研发中心 北京100190
Published Online:2013-09,
Published:20 September 2013
移动端阅览
Bin Fu, Xin Yang, Song Wang, et al. Research on WebRTC Technology and Application[J]. Telecommunications science, 2013, 29(9): 108-112.
Bin Fu, Xin Yang, Song Wang, et al. Research on WebRTC Technology and Application[J]. Telecommunications science, 2013, 29(9): 108-112. DOI: 10.3969/j.issn.1000-0801.2013.09.021.
WebRTC技术在浏览器上直接实现语音、视频和文件共享等业务,极大地提高了使用的便利性。由于其开源和开放,使得VoIP应用的开发更为简单和快速。在对WebRTC进行介绍的基础上,分析了其发展趋势以及对运营商通信业务的影响,与IMS进行了对比,然后对WebRTC与IMS结合的3种方式进行了讨论。最后,对目前WebRTC的主要研究方向进行了介绍,展望了未来的发展趋势。
WebRTC technology enables audio
video communication and file sharing services over web browsers without installing add-ons
which improves the convenience of such applications greatly. Its openness and open source policy will simplify and facilitate the development of applications. WebRTC technology was introduced
and then the trend and influence on operator's communication services were analyzed. A comparison and three ways of combination with IMS were depicted as well. At the end
a summary of research topics and overview of future development were given.
WebRTC . http://www.webrtc.org http://www.webrtc.org
W3C HTML5 . http://www.w3.org/TR/html5/ http://www.w3.org/TR/html5/
W3C WebRTC Workgroup . http://www.w3.org/2011/04/webrtc-charter.html http://www.w3.org/2011/04/webrtc-charter.html
W3C WebRTC API . http://dev.w3.org/2011/webrtc/editor/webrtc.html http://dev.w3.org/2011/webrtc/editor/webrtc.html
IETF RTCWeb Workgroup . http://tools.ietf.org/wg/rtcweb/charters http://tools.ietf.org/wg/rtcweb/charters
3GPP TR 23.701. Study on the Support of WebRTC IMS Client Access to IMS , 2010
IETF RFC5245. ICE(interactive connectivity establishment) . http://tools.ietf.org/html/rfc5245 http://tools.ietf.org/html/rfc5245 , 2010
IETF RFC5389. STUN(session traversal utilities for NAT) . http://tools.ietf.org/html/rfc5389 http://tools.ietf.org/html/rfc5389 , 2008
IETF RFC5766. TURN (traversal using relays around NAT) . http://tools.ietf.org/html/rfc5766 http://tools.ietf.org/html/rfc5766 , 2010
IETF RFC6716. Opus(definition of the opus audio codec) . http://tools.ietf.org/html/rfc6716 http://tools.ietf.org/html/rfc6716 , 2013
IETF RFC3261. SIP(session initiation protocol) . http://tools.ietf.org/html/rfc3261 http://tools.ietf.org/html/rfc3261 , 2002
IETF RFC3264. SDP(session description protocol) . http://tools.ietf.org/html/rfc3264 http://tools.ietf.org/html/rfc3264 , 2010
IETF RFC6455. The Web socket protocol . http://tools.ietf.org/html/rfc6455 http://tools.ietf.org/html/rfc6455 , 2011
0
Views
1072
下载量
0
CSCD
Publicity Resources
Related Articles
Related Author
Related Institution
京公网安备11010802024621